Skip to content

GPU Video analytics module installation

System requirements for Flussonic's GPU video analytics module

  • OS: x64 Ubuntu 20.04 or 22.04.
  • GPU: NVIDIA with at least 6 GB VRAM.

    When choosing a compatible video card, pay attention to the Compute Capability version: Watcher supports Compute Capability 6.1, 7.5 and 8.6. You may refer to the Nvidia website for selecting a video card with supported Compute Capability version.

    See also Calculating video memory for analytics on GPU.

  • CPU: 4+ cores

  • RAM: 8+ GB

Installing the Flussonic video analytics module

Run the commands:

apt update
apt install --no-install-recommends nvidia-driver-525
apt install flussonic-vision