This is a readonly text dump of old forum. New forum https://forum.flussonic.com
Обсуждение эрливидео

Проблемы с обновлением

Added by Александр Драгой almost 2 years ago

После обновления версии 4.6.1 до версии 4.6.3 перестал стартовать Flussonic. Выдает такую ошибку: =ERROR REPORT==== 30-Aug-2016::10:31:53 === Loading of /opt/flussonic/apps/config2/ebin/config2_disk.beam failed: badfile =ERROR REPORT==== 30-Aug-2016::10:31:53 === beam/beam_load.c(1061): Error loading module config2_disk: not a BEAM file: no IFF 'FOR1' chunk escript: exception error: undefined function config2_disk:read/0 in function validate_config:main/1 (tmproot/tmpnam-validate_config-1472151728845834.erl, line 7) in call from escript:run/2 (escript.erl, line 757) in call from escript:start/1 (escript.erl, line 277) in call from init:start_it/1 in call from init:start_em/1 При откате до версии 4.6.2 все работает.

Replies (3)

RE: Проблемы с обновлением
added by Vladimir Gordeev almost 2 years ago
нужно обновить пакет flussonic-erlang
RE: Проблемы с обновлением
added by Max Lapshin almost 2 years ago
centos, да. Надо руками следить за всеми обновлениями. Эрланг тоже обновился.
RE: Проблемы с обновлением
added by Александр Драгой almost 2 years ago
ОС: CentOS Linux release 7.2.1511