This is a readonly text dump of old forum. New forum https://forum.flussonic.com
Обсуждение эрливидео

Проблема с Flussonic !&

Added by serg www almost 2 years ago

Проблемы с вещанием на флюсоник конфигурация примерно такая 300 tshttp стримов трафик порядка 800мбит на выходе , CPU E3-1231 3.40GHz, 8 cores, 32Гб RAM спустя 8-10 часов работы флюсоника стримы периодически начинают подвисать , после перезагрузки флюсоника опять все норма на 8-10 часов потом опять нужно рестартить MEM | tot 31.2G | free 512.7M | cache 22.7G | dirty 95.9M | buff 47.3M | slab 774.8M | SWP | tot 1.0G | free 922.8M | | так понимаю проблема с памятью, подскажите как оптимизировать ?

Replies (4)

RE: Проблема с Flussonic !&
added by Maksim Klyushkov almost 2 years ago
Обновитесь до последней версии, попробуйте отключить неиспользуемые протоколы. Если проблема будет сохраняться, опишите подробнее, как зависают потоки. Приложите логи.
RE: Проблема с Flussonic !&
added by serg www almost 2 years ago
убрал SWAP но все равно периодически вылазит эта проблема..какие еще рекомендации можете дать ?
RE: Проблема с Flussonic !&
added by Max Lapshin almost 2 years ago
первое дело, которое надо всегда без исключений делать на свежеустановленном сервере — выключать своп, включая fstab тоже.
RE: Проблема с Flussonic !&
added by serg www almost 2 years ago
в sysctl прописано так: net.core.wmem_max = 16777216 net.ipv4.tcp_wmem = 4096 4194394 16777216 net.core.rmem_max = 1048576 net.core.rmem_default=1048576 net.ipv4.udp_mem = 8388608 12582912 16777216